头像
jiayiming
帖子: 8
注册时间: 2011-04-21 20:15

请问这结果是我这x264中哪个参数造成的

2012-02-27 23:29

源LanczosResize到720P的效果
EP1.avs_20120227_225915.554.jpg
我avs后的效果,taa试了几套搭配也没什么效果,干脆不用了。。

代码: 全选

FFmpegSource2(X,atrack=-2) ConvertToYV12() SeparateResize(1280, 720, 0, 0, 0, 0, LumaR="Spline64Resize", ChromaR="SoftCubicResize", nr=true, matrix="Rec709", info=false) #taa() f3kdb(range=12,output_mode=2,output_depth=10)
EP1.avs_20120227_231857.698.jpg
结果用下面参数给10bit_tMod就这效果。。杏子左侧发丝的黑线条非常模糊,左下角和左上角也损失非常大,是哪里出了问题?试过crf=8,关psy-rd也仅仅好了一点点而已。。。各位有什么推荐修改的参数

代码: 全选

"c:\Tools\x264 tMod\x264_32_tMod-10bit-all.exe" --crf 18 --level 5.1 --input-depth 10 --ref 9 --deblock 0:0 --me umh --subme 10 --psy-rd "0.80:0.00" --mixed-refs --merange 32 --trellis 2 --no-fast-pskip --bframes 8 --b-adapt 2 --direct auto --keyint 240 --min-keyint 1 --qcomp 0.70 --cplxblur 20.0 --qblur 0.5 --aq-mode 2 --aq-strength 0.9 --threads auto --ssim --log-file-level debug --log-file "EP1.log" --output "EP1.mkv" "EP1.avs"
Mahou Shoujo Madoka Magica EP01 [Bluray 1280×720 x264 Hi10P FLAC].mkv_20120222_162752.868.jpg

头像
mawen1250
核心会员
核心会员
帖子: 670
注册时间: 2011-07-24 20:33

Re: 请问这结果是我这x264中哪个参数造成的

2012-02-27 23:35

试试
--crf 17 --no-mbtree
类似的情况我在压Kanon时也碰到过,主要是mbtree对于码率分配的bias作用导致这种地方分配到过低的码率,于是索性关了mbtree就没问题了,但这只适用于crf较低的情况(通常小于等于17),要追求小体积的话mbtree还是要开的。

头像
jiayiming
帖子: 8
注册时间: 2011-04-21 20:15

Re: 请问这结果是我这x264中哪个参数造成的

2012-02-28 13:16

mawen1250 写了:试试
--crf 17 --no-mbtree
类似的情况我在压Kanon时也碰到过,主要是mbtree对于码率分配的bias作用导致这种地方分配到过低的码率,于是索性关了mbtree就没问题了,但这只适用于crf较低的情况(通常小于等于17),要追求小体积的话mbtree还是要开的。
关了后好点了 不过和AVS预览差别还是很大。。
附件
EP1.mkv_20120228_131402.844.jpg

turtlemark
帖子: 2
注册时间: 2012-02-28 13:50

Re: 请问这结果是我这x264中哪个参数造成的

2012-02-28 14:00

LZ是追求“还原”还是追求“不模糊”的效果?
如果追求“还原”,那只能靠码率。欠码的话无论如何都搞不定。
如果只是想要“不模糊”的效果,那就deblock取负值。这种处理方法在压动画的时候挺常见的。
不过看LZ特意加了ssim测试似乎很在意还原度。

头像
mawen1250
核心会员
核心会员
帖子: 670
注册时间: 2011-07-24 20:33

Re: 请问这结果是我这x264中哪个参数造成的

2012-02-28 16:22

嘛,像这种关了mbtree时还模糊,除了进一步提升码率是没啥办法的了,基本上crf降到16以下就不容易察觉到了。
PS. 如果你学会了200%放大对比大法,可能crf=15都不能满足你了。

我当时在压Kanon时碰到了这个问题,然后就从psy-RDO(从0.4到1.0)、psy-trellis(从0.0到0.25)、aq-mode(从2到1)到deblock(从0:0到-2:-2)一个个参数试过来,发现不是没什么效果就是效果更差。然后关了mbtree才解决。

关于deblock参数我做过两次主观画面对比,每次我比较的结果都是0:0还原出的画面最好,而且我也实在看不出来负值能带来什么样的好处,正值例如1:1的话主要用于码率不足时减轻block,码率足够的话通常就不要用。
deblock和SSIM没什么关系,主要是psy-rd的作用会降低SSIM。

有关deblock的讨论可以看这里:http://forum.doom9.org/showthread.php?t=163182

头像
jiayiming
帖子: 8
注册时间: 2011-04-21 20:15

Re: 请问这结果是我这x264中哪个参数造成的

2012-02-28 23:14

我主要是追求还原度。。。想尽量减少编码时候的损失
结果又试了n圈 的确加码率是硬道理。。。我就是在放到300%对比时候发现这个问题的。。

turtlemark
帖子: 2
注册时间: 2012-02-28 13:50

Re: 请问这结果是我这x264中哪个参数造成的

2012-02-28 23:42

LZ要是实在喜欢小圆又纠结还原度,干脆收个大体积的1080P好了。某些BDrip组做的片子虽然参数乏善可陈,但码率绝对给够。

回到 “视频编码器 / Video encoder discussion”